Got a working amiga again. \o/ woot Needed to replace Paula chip, cleaning and some TLC.
Modulator
Chip donor
Scart cable i’ve got is one without the resistors, so my monitor isn’t detecting the signal. Using a A520 modulator works. At least RF, don’t know why RCA/composite video isn’t working.
Even a memory expansion and second drive (5.24 inch) are working.
One of the first disks i tested
To do:
Fix something to get disk images from and to my pc.
(My old catweasel card only fits in a ISA slot which i don’t have any more)
I was wrong .. i’ve got a IV Catweasel .. PCI it is
Fix scart
Fix my Action Replay, which i soldered into a non working state apparently .. 🙂
Get a better mouse!
Catweasel IV
Kickstart selectorAction Replay
Disks to convert:
Personal text files from ages ago
My first seka demo
My oscillator drawing program
Other assembly source files
Got another one running today also:
Olivetti M21 machine you could carry with you. 9″ screen, 640K memory, 8086 Cpu
Script NO1: Below is a script which checks all sensors and switches available on my domoticz instance, and gives me information about last updates. For example when a device is out of reach or battery empty.
Usage:
Outputs to console, or you can use it in check_mk monitoring. (For the latter, create a script
vi /usr/lib/check_mk_agent/local/checkfrontdoor
chmod +x /usr/lib/check_mk_agent/local/checkfrontdoor
put in the script
#!/bin/bash
cd /path/to/script/
./belowscript "Frontdoor" 300 checkmk
Code:
#!/bin/bash
#set -x
# after running once check stateseconds for names
if [ $# -eq 0 ]; then
echo "$(basename $0) - without options .. getting states"
echo "use $(basename $0) "Sensorname" seconds" for check
echo "Getting all states"
: > stateseconds
curl -s -i -H "Accept: application/json" "http://127.0.0.1:8080/json.htm?type=devices&filter=all&used=true&order=Name" | egrep "Name|Last" | grep -v HardwareName |grep -vi levelnames> states
sed -i 'N;s/\n/,/' states
now=$(date +%s)
cat states | awk '{ print $3" "$4$7$8$9$10$11$12 }' | sed s/,,/,/g |rev | cut -c2- | rev | while read ; do
name="$(echo $REPLY | cut -f2 -d, )"
dater="$(echo $REPLY | cut -f1 -d, | sed s/\"//g)"
#echo $dater
seen=$(date -d "$dater" +%s)
#echo $seen
echo "$name $(( $now - $seen))" >> stateseconds
echo -n "."
done
fi
echo ""
if [[ ! -z "$1" && ! -z $2 ]]; then
checkold=$(cat stateseconds | grep "$1\"" | head -1 | awk '{ print $2 }')
total=$(( checkold - $2 ))
if [ -z $3 ] ; then
if [ $checkold -gt $2 ] ; then echo "$name lastseen longer than $2 seconds ago ($total sec)" ; exit 1 ;fi
else
if [ $checkold -gt $2 ] ; then echo "2 \"$1\" - Sensor older than $2 seconds" ; exit 1
else
echo "0 \"$1\" - Sensor age ok" ; exit 0
fi
fi
fi
Dry salmon, put a layer of above mixture in a container, put the salmon on top, with another layer. Put a heavy weight ontop to squeeze the water out of the salmon, while its in the refrigerator. Next day: Wash the salmon, drying it with paper kitchentowel. Put the salmon back into the refrigerator again to dry some more. I’ve put the salmon in my smoker with a cold smoke generator for 8 hours, the cheese needed only 2 hours.
A long time ago i took a book about doing funny stuff in dos, and wrote own additions in the sidelines of the book. Or used the empty pages.
It contains jokes using autoexec.bat and config.sys. Additions by me are most of the time things you could do with debug.com, a little program which existed on any pc at that time.
A little program which created static on a CGA or Hercules monitor. Yes, that long ago. CGA provided 16 colors in 80×25 or 40×25 text modes, but only four colors at 320×200 resolution and two colors at 640×200. Hercules was only monochrome and a max resolution of 720×348. It was on a hercules card i made my first copperbar. ( Before the effect was named copperbar ). Due to difference in timing on every machine, you had to get the copperbar timing right by using two keys i’d assigned the timing to.
MOV AL,00 # Fill AL register with 0
MOV DX,0x03D8 (cga) 03B8 (herc)# DX with address
OUT DX,AL # Set address with AL
MOV AL,[0101] # Reg AL with contents
INC AL # Increment AL
MOV [0101],AL # Address fill with AL
JMP 100 # Jump to start
The opcodes for the program :
b0 00
66 ba d8 03
ee
a0 41 00 00 00
fe c0
a2 41 00 00 00
e9 60 00 00 00
Sometimes i put these little programs in autoexec.bat, so at next restart of the pc, it would do something weird. My little BOFH jokes. Friends and computerstores where not safe.
Another example:
Two drives in a PC ? (Wie A: zegt moet ook B: zeggen) Use with care, below will f*ck up your drives. (And makes a lot of noise while doing so.)
MOV DX,0x03F2
MOV AL,71
OUT DX,AL
MOV AL,74
OUT DX,AL
JMP 100
20220502: Fixed another C64, PIA (Peripheral Interface Adapter) was dead, luckily i’ve got several spare-part c64’s. So that was a easy fix.
20220504: Got my sd2iec adaptor in, see bottom of this page.
Booting with a power cartridge
None of my old computers was unmodified
Demo by my old friend Sepp
Drive is a 1541model 2
De wires are going to the DOUT pins of the memory chips. Showing activity using leds. Sometimes i monitored CS .. also informative.
SD2IES Cardreader
Little small funky gadget, it replaces a 1541 Floppy drive with a SDCard reader where you can store a lot of floppydisk images on. More on this later.
NOTE : Doesn’t work together with my KCS Power cartridge.
CartridgeScreen
I’ve tested two cartridges.
Final cartridge III fastload test on a program did ~3 seconds. ( Normal load time ~17 seconds. ) KCS powercartridge didn’t work. Tip: press `runstop` when using FC3 while turning on to get into basic not the desktop.
I made two scripts, which take a movie, find out its lenght divide by 9. And generates a image montage of snapshots at certain times in the movie. ( A movie of 90 minutes, gets a snapshot every 10 minutes )
Example of snapshots of a movie
Below takes images as above and convert them into animated gifs. All movies in a path or directory structure gets a index page containing all animated gifs.
Example of generated directory index
I’ll post something about my media sorter also. A ajax website using drag drop viewing/sorting images (png/gifs/jpgs) and movies.
I made a sound mixer controller for my applications, a while ago.
Some arduino project laying around on my desk. (OBS controller, Mqtt-sound-and-display-with-mute-acknowledge-button and Octoprint monitor, below that my dusty mixer)
I’m probably make a V2 with new functionality:
Switching applications which are using sound from speakers to headset and vice versa.
Today Vincent mentioned a link about mqtt and mikrotiks, i knew about addons, but not mqtt .. lets try this.
When you want to use MQTT with Mikrotik you have to install the iot package from extra_packages.
Download correct package zip from ( https://mikrotik.com/download )
Download extra packages zip for your system
Extract and use file upload
Reboot your mikrotik
(i had to upgrade my firmware first, iot package was not build for my version)
Create a entry in IoT > Mqtt to your broker.
save below in a script ending with a .rsc extention, and upload in file manager
# Required packages: iot
################ Configuration #################
# Name of an existing MQTT broker that should be used for publishing, the one you just created
:local broker "10.1.0.17"
# MQTT topic where the message should be published
# i've got mine in a tree called mikrotik/switchtype/
:local topic "mikrotik/rb2011/topic"
############### System ###############
# You can create your own variables below
:put ("[*] Gathering system info...")
:local cpuLoad [/system resource get cpu-load]
:local freeMemory [/system resource get free-memory]
:local usedMemory ([/system resource get total-memory] - $freeMemory)
:local rosVersion [/system package get value-name=version \
[/system package find where name ~ "^routeros"]]
:local model [/system routerboard get value-name=model]
:local serialNumber [/system routerboard get value-name=serial-number]
:local upTime [/system resource get uptime]
################## MQTT ###################
# create a message
:local message \
"{\"model\":\"$model\",\
\"sn\":\"$serialNumber\",\
\"ros\":\"$rosVersion\",\
\"cpu\":$cpuLoad,\
\"umem\":$usedMemory,\
\"fmem\":$freeMemory,\
\"uptime\":\"$upTime\"}"
:log info "$message";
:put ("[*] Total message size: $[:len $message] bytes")
:put ("[*] Sending message to MQTT broker...")
/iot mqtt publish broker=$broker topic=$topic message=$message
:put ("[*] Done")
Import script using
import mikrotikmqtt.rsc
Todo’s:
Import is just @ import time, need to “cron” this?
"If something is worth doing, it's worth overdoing."